abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Optolink Switch (Splitter) - Vitoconnect, MQTT & TCP/IP

 

Moin ihr! 🙂

 

Optolink ist 'alt', aber noch in Benutzung (bei mir auch). Öfter gab es Anfragen zum Betrieb zu lokalen Zwecken aber trotzdem weiter das Vitoconnect für Viessmann Cloud/Vicare/Viguide/Vi.API/Garantieverlängerung zu benutzen. Dazu jetzt hier die benutzerfreundliche Lösung, natürlich wieder open-source und kostenlos:

 

der OptolinkVs2-Switch

HerrP_0-1713897747645.png

 

Er verbindet euer Optolink Gerät auf total einfache Weise mit allem was das Herz begehrt.

  • Home Automation Anbindung per MQTT
  • W/LAN Anbindung per TCP/IP und einfachen Ascii + $Hex
  • Parallelbetrieb des Vitoconnect und damit Vicare, Viguide, Viessmann API weiter nutzbar und Erhaltung der erweiterten Garantie

Kein Gehassel mit komplizierter Einrichtung und irgendwelchen kryptischen xml's. Einfach nen Raspi, ein paar Python Module draufkopiert, Optolinkadapter und bei Bedarf das Vitoconnect angesteckt, ggf. noch ein paar Anpassungen in der Settings_ini (COM Ports, IP Adressen, MQTT Passwort, Poll-Liste, ...) und los.

 

HerrP_2-1713897813860.png

 

viel Spass damit & Grüsse!

Phil 🖖

 

 

12 ANTWORTEN 12

gut dass ich das Ding zumindest selber brauchen kann. ausser den Beiden, für die ich's gebaut hab, schein ja sonst niemand Interesse dran zu haben 😎 Wahrscheinlich ist die Optolink-(Betreiber-)Generation so alt, dass da niemand was mit Hausautomatisierung am Hut hat oder alles schon fertig...

Aber im HT Forum sind noch Fragen offen.

 

@qwert089  oh besten Dank Michael! immer dieser Benachrichtigungs-Issue im Haustechnikdialog.... 😴

ich hab ein kleines Video gemacht - kurze Einführung in die vielfältigen Möglichkeiten und die Einfachheit der Benutzung des Optolink-Switch

 

https://youtu.be/95WIPFBxMsc

Hallo @HerrP ,

sie sind keineswegs der einzige. 

Schon vor mehreren Wochen hat mich @qwert089 in meinen thread auf die neue möglichkeit aufmerksam gemacht. 

Nur leider hatte ich noch keine Zeit es umzusetzen. Das werde ich ändern demnächst tun. Da ich Loxonebenutzer bin, werde ich versuchen, wenn es für dich OK ist, dann ein Plugin für den loxberry zu erzeugen.

Liebe Grüße und vielen Dank für deine Arbeit.

immer gerne! 🙂 es lebe open source! 🖖 Es gibt inzwischen auch eine Version, die auch mit dem älteren KW Protokoll funktioniert (Schater in der settings_ini). Da ist allerdings die Start-up Sequenz mit Vitoconnect noch nicht getestet, der Rest ist schon im Einsatz. Wenn man irgendwas neues bastelt, wäre es vlt gut, gleich da drauf aufzusetzen, irgendwann kommt doch wieder jemand mit KW Protokoll...

Guten Tag HerrP,
Ich versuche, Optolink-Switch mit meiner Wärmepumpenanlage Vitocal 300-G zu verwenden. Der Anschluss klappt gut. Mit serLog.py wird der Informationsaustausch zwischen Vitoconnect und Vitocal korrekt ausgelesen und protokolliert. optolinkvs2_switch.py gibt jedoch einen Fehler aus: List index out of range. Wenn ich die Polling disable dan bekomme ich keine Fehler.

Die console output geht hierbei, also auch ein pdf mit die output von serlog.py. Können sie mich berichten wie ich dass lösen soll.

Hertzlichen Grüss,
Frans

awaiting VS2...
Broker granted the following QoS: 0
VS detected
rx 06
rx 41 05 00 41 00 F8 01 3F
rx 41 0D 01 01 08 8E 08 AE 0B 55 00 AE 0B AE 0B 2D
list index out of range
exit close
closing serViCon
reset protocol
closing serViDev
cancel poll timer
exiting TCP/IP client
disconnect MQTT client
closing vitolog

Moin Frans!

 

ich denke du hast die poll_items List in der settings_ini.py angepasst? ich vermute, da ist ein syntaktischer Fehler reingerutscht, ein Komma zu viel oder zu wenig oder ein Indent Problem oder sowas.

 

Könntest du die settings_ini.py mal hier hochladen?! du musst die Dateiendung ändern in .txt oder so.

Und wenn Passwords drin sind, diese vorher löschen/ersetzen!

 

Grüsse!

Phil

 

Hallo Phil,

Weil ich noch nicht genau weiss welche Items für meine Anlage geeignet sind, habe ich nur die Anlagezeit und Aussentemperatur in meine Poll-liste.

Files mit txt endung kan ich auch nicht hochladen, nur pdf, jpg, jpeg, png, gif, bmp, wbmp, mp4, mov. sind gültige Datatypen.

Ist es vielleicht bequemer diese Discussion fort zu setzen in Github?

 

> Ist es vielleicht bequemer diese Discussion fort zu setzen in Github?

ja, das sollten wir tun! machst du bitte eine Discussion oder ein Issue auf!?

 

In der settings_ini kann ich so erstmal nix Fehlerhaftes erkennen, es kann aber sein, dass was mit Indent in der Leerzeile ist oder so. Lade bitte die settings_ini auf github noch mal als Text File hoch.

 

und versuch mal

    ("Anlagenzeit", 0x088E, 8, 'vdatetime'),

zu ersetzen durch

    ("Anlagenzeit", 0x088E, 8, 'raw'),

 

damit wir den vdatetime 'Codec' schon mal ausschliessen können.

 

Wir können auch auf Englisch weiter schreiben (auf github), wenn das bequemer für dich ist.

 

 

 

ich habe es schon gesehen... deine Anlage überträgt die Zeit anders als die Vitodens:

 

rx 41 0D 01 01 08 8E 08 AE 0B 55 00 AE 0B AE 0B 2D

 

41 0D : STX, 13 Bytes Payload

    01 01 : Antwort auf virtual read request

        08 8E : DP Adresse

           08 : 8 bytes data

AE 0B 55 00 AE 0B AE 0B : das ist ein anderes Format. Der 'Index out of Range' kommt bei 

 

    weekdays = ['Mo', 'Di', 'Mi', 'Do', 'Fr', 'Sa', 'So']
    wkd = weekdays[int(data[4]) - 1]

    

 data[4] ist AE, weekdays[0xAD] gibt es nicht...

 

 

Stimmt, ich habe die Analagezeit entfernt und jetzt lauft er mit nur die Aussentemperatur. Ich soll aber die ganze Datenpunktenliste neu machen. Der Aussentemperatu gibt immer 0, so ist auch nicht richtig codiert.

Message 4 received on vitocal/AussenTemp at 1:56 PM:
0
QoS: 0 - Retain: false

Top-Lösungsautoren